You need MSXML 4.0 SP2

by on April 22, 2010

Q: I am running Windows Vista. I want to clean out my system of items I don’t need and when I go to add/remove programs I see some items I don’t know anything about. Do I need these programs?

*MSXML 4.0 SP2 (KB927978) – Microsoft
*MSXML 4.0 SP2 (KB936181) – Microsoft
*MSXML 4.0 SP2 (KB941833) – Microsoft
*MSXML 4.0 SP2 (KB954430) – Microsoft
*MSXML 4.0 SP2 (KB973688) – Microsoft

A: Yes you need these. These are updates that Microsoft releases for their operating system and they are usually released to fix bugs or to fix security holes. The nice thing is anything released by Microsoft usually has a KB (knowledge base) number and that can be used to find out more information about the specific item.

You can get to the knowledge base description by typing in http://support.microsoft.com/kb/[number] so for the last example that was given you would type in http://support.microsoft.com/kb/973688 and this would give you all the information there is to know about the updates. I have taken the liberty of linking to each knowledge base item above so everyone can see more detailed information about why each update is so important.

Read Question Here