How come I cannot get my user merge to work correctly on my wiki? 

by on March 19, 2012

Q: I have a wiki ( I’m trying to add a user merge and delete function onto my wiki using the info here ( I downloaded and extracted the extensions to my extensions folder, and then I added the following code to the end of my LocalSettings.php

require_once( “” );
$wgGroupPermissions['bureaucrat']['usermerge'] = true;

# optional – default is array( ‘sysop’ )
$wgUserMergeProtectedGroups = array( ‘groupname’ );

And it breaks my wiki. I get the following error:

Warning: require_once( [function.require-once]: failed to open stream: No such file or directory in /home/deabrynspikess/ on line 161

Fatal error: require_once() [function.require]: Failed opening required ‘’ (include_path=’/home/deabrynspikess/’) in /home/deabrynspikess/ on line 161

If I delete “require_once” from the code on the LocalSettings.php, then my wiki will work again, but a new Special Page Special:UserMerge with the title Merge and Delete Users was never created. What am I doing wrong?