How come I cannot get my network card to work with openSUSE 11?

by on November 25, 2009

Q: my network card don’t work my OS is : opensuse 11
the network card’s type: Realtek RTL8186C(P)/8111C(P) pci-e gigabit ethernet.
some said that because of the dual boot with xp and i have to set a “wake on lan after shutdown” property of windows and i found it already set .

this is the commands, remember iam new on linux and can’t compile the kernel or kernel header or all this stuff in case u wanna me 2 do , so include a tutorial or steps thx.

Quote:
linux-g0ss:~ # route -n
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
127.0.0.0 0.0.0.0 255.0.0.0 U 0 0 0 lo

linux-g0ss:~ # ifconfig -a
eth0 Link encap:Ethernet HWaddr 00:1F0:8A :77:AA
inet6 addr: fe80::21f:d0ff:fe8a:77aa/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:4294966980 overruns:0 frame:0
TX packets:0 errors:0 dropped:710 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 b) TX bytes:0 (0.0 b)
Interrupt:219
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:910 errors:0 dropped:0 overruns:0 frame:0
TX packets:910 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:83124 (81.1 Kb) TX bytes:83124 (81.1 Kb)

linux-g0ss:~ # hwinfo –netcard
09: PCI 400.0: 0200 Ethernet controller
[Created at pci.310]
UDI: /org/freedesktop/Hal/devices/pci_10ec_8168
Unique ID: rBUF.U9HbhyH+WU7
Parent ID: HnsE.cl8tOgOWATC
SysFS ID: /devices/pci0000:00/0000:00:1c.5/0000:04:00.0
SysFS BusID: 0000:04:00.0
Hardware Class: network
Model: “Realtek RTL8111/8168B PCI Express Gigabit Ethernet controller”
Vendor: pci 0x10ec “Realtek Semiconductor Co., Ltd.”
Device: pci 0x8168 “RTL8111/8168B PCI Express Gigabit Ethernet controller”
SubVendor: pci 0x1458 “Giga-byte Technology”
SubDevice: pci 0xe000
Revision: 0xff
Driver: “r8169”
Driver Modules: “r8169”
Device File: eth0
I/O Ports: 0xd000-0xdfff (rw)
Memory Range: 0xea010000-0xea010fff (rw,prefetchable)
Memory Range: 0xea000000-0xea00ffff (rw,prefetchable)
IRQ : 219 (no events)
HW Address: 00:1f:d0:8a:77:aa
Link detected: yes
Module Alias: “pci:v000010ECd00008168sv00001458sd0000E000bc02sc0 0i00”
Driver Info #0:
Driver Status: r8169 is active
Driver Activation Cmd: “modprobe r8169”
Config Status: cfg=no, avail=yes, need=no, active=unknown
Attached to: #21 (PCI bridge)
hope to get a quick help plz.
Reply With Quote


2 Responses to “How come I cannot get my network card to work with openSUSE 11?”
  1.  

    Just in case no one posts here that has any openSUSE experience, you might want to try over at the openSUSE forums: http://forums.opensuse.org/

     
  2.  

    This is where I usually make sure that the network card I buy is 100% compatible with the version of linux I am going to use before I buy the network card. Sorry I cannot be any more help than that.